Blog

1C (13)

Функция ПроверитьСуществованиеЗаписиПоФильтру(Таблица, СтруктураФильтров)
 пСеанс = ВнешниеИсточникиДанных.opcart.ПолучитьОбщиеПараметрыСоединения();
 ЗапросSQL = "Select * from " + Таблица + " Where";
 а = 0;
 Для Каждого Элемент Из СтруктураФильтров Цикл
  ЗапросSQL = ЗапросSQL + ?(а = 0, " ", " AND ") + Элемент.Ключ + " = " + Элемент.Значение;
  а = а + 1;
 КонецЦикла;

 Connection = Новый COMОбъект("ADODB.Connection");
 Connection.CursorLocation = 3;
 Connection.CommandTimeout = 60;
 Connection.ConnectionTimeOut = 60;
 Command = Новый COMОбъект("ADODB.Command");
 RecordSet = Новый COMОбъект("ADODB.RecordSet");
 Connection.Open(СокрЛП(пСеанс.СтрокаСоединения)+"UID="+пСеанс.ИмяПользователя+";PWD=PASSWORD;"); 
 Command.ActiveConnection = Connection;
 Попытка
 Command.CommandText = ЗапросSQL;
 RecordSet = Command.Execute();
 НашеЗначение = RecordSet.EOF; //Истина - записи нет
 Connection.Close();
 Возврат НашеЗначение;
 Исключение
 Сообщить(ОписаниеОшибки());
 Connection.Close();
 Возврат Истина;
 КонецПопытки;
КонецФункции

Готовый скрипт для выгрузки прайса с программы Morion Аптека на ресурс Liki24. Стоимость скрипта с подключением к вашей базе - 1500 грн

Логика работы скрипта:

- Подключение к базе данных Morion Аптека

- Извлечение остатков, цен и торговых точек

- Формирование файлов для отправки по ФТП (первый файл - список торговых точек; второй файл - остатки с ценами в разрезе ТТ)

- Выгрузка на ФТП Liki24

Выгрузка будет происходить автоматически в указанный промежуток времени.

 

//Обновим Описание
МассивИзменяемыхПолей = Новый Массив;
МассивИзменяемыхПолей.Добавить("name");
МассивИзменяемыхПолей.Добавить("description");

дПозицияДляРедактирования = ВнешниеИсточникиДанных.opcart.Таблицы.oc_product_description.НайтиПоПолю("product_id",дНашИД);
дОбъект = дПозицияДляРедактирования.ПолучитьОбъект();
дОбъект.УстановитьИзменяемыеПоля(МассивИзменяемыхПолей);
дОбъект.name = дНоменклатура.НаименованиеНаСайте;
дОбъект.description = СокрЛП(дНоменклатура.ПодВидЗапчасти.Наименование) + "
" +Выборка.Описание;
дОбъект.Записать(); //--Обновим описание

Текст ошибки: Ошибка при вызове конструктора (COMОбъект): -2147467262(0x80004002): Интерфейс не поддерживается

Решение: Пуск - Выполнить Regsvr32 C:\Program Files (x86)\1cv8\8.3.16.1224\bin\comcntr.dll

Если 1С работает в клиент-серверном варианте (либо через тонкий клиент), когда сервер находится не на том компьютере где запускается 1С клиент - Директивы &НаКлиенте &НаСервере становятся как никогда актуальными.

Если вы работали на одном сервере, а в один прекрасный момент перенесли базу на другой сервер, при этом запуск клиента 1С остался на старом сервере - половина ваших обработок которые вы написали однозначно перестанут работать.

Наглядный пример, как можно решить проблему переброски файла через временное хранилища между сервером и клиентом: 

&НаСервере
Процедура ПрочитатьФайлТабДоком(ИмяФайла)
ДвоичныеДанные = ПолучитьИзВременногоХранилища(ИмяФайла);
ИмяВременногоФайлаXML = ПолучитьИмяВременногоФайла("XLSX");
ДвоичныеДанные.Записать(ИмяВременногоФайлаXML);
Данные = Новый ТабличныйДокумент;
Данные.Прочитать(ИмяВременногоФайлаXML);
КонецПроцедуры

с 1 декабря 2018 года вступила в силу новая форма налоговой накладной и расчета корректировки) (F)J1201010. После того как вы обновили 1с 7.7 до версии 7.70.331 - медовая стыковка выгружает старые налоговые?

 стыковка для 7 7

 стыковка для 7 7

 стыковка для 7 7 v 3 9

Обращайтесь по телефону +38(044) 364-3769

 

 

Если работа аптечной сети построена по схеме Центральная база и удаленные узлы (кассы) и между ними регулярно происходит обмен, тогда для касс понадобится следующая инструкция:

Когда разработчики вносят изменения в конфигурацию в центральной базе 1С, после обмена она выгрузится на кассы и эти изменения нужно применить. Пока вы не примените обновления - все обмены будут остановлены.

1) На каждом кассовом месте мы должны зайти в конфигуратор

 1с 8

2) Открыть конфигурацию, как это показано на картинке (Иногда она может быть уже открыта, это когда вы видите в левой части экрана дерево)

obmen 1C apteka

3) Нажать синий боченок (или F7), и дальше соглашаться со всем что будет предложено. После обновление закрываете программу и заходите в обычном режиме делаете обмен и продолжаете работать

obmen 1C

на примере УТ 3.0

Распределение дополнительных расходов на себестоимость товаров обычно происходит в конце месяца. Для распределения расходов на себестоимость товаров используется регламентированная обработка Закрытие месяца.

3

на примере УТ 3.0

В программе можно учитывать различные виды дополнительных расходов при поступлении товаров. Например, создаем документ Поступление товаров и услуг  с поступлением товара. Далее рассмотрим поступление допуслуг и расчёт себестоимости товара по данному примеру.

 1

Все виды дополнительных расходов фиксируются в документе Поступление товаров и услуг в качестве дополнительных услуг

Счетчики

 

 

Киев, Новозабарская, 2/6

+38(044)233-3017      +38(093)170-3017