Blog

Задержка в 1С (delay)

Иногда требуется в 1с перед началом следующего цикла использовать задержку, например когда приходится отправлять много файлов п фтп.

Вариант первый:

ЗадержкаСекунд = 15;
шел = СоздатьОбъект("WScript.Shell");
шел.Run("ping 127.0.0.1 -n "+СокрЛП(Число(ЗадержкаСекунд)),0,1);

В таком случаи файлы успевают загрузится на фтп и перейкти к следующему файлу. Недостатки такого вариант очевидны.

Вариант второй:

Перед началом следуюещего выполнения в цикле - проверить наличие файла на сервере

Функция ПроверитьФайлНаФТП(прКаталог, прФайлФТП, прИмяФайла)
    РазмерФайлаФТП = FTP.ПолучитьРазмерФайла(прФайлФТП);  
    лпРазмер = 0;
    Если (ФС.СуществуетФайл(прИмяФайла) = 1) Тогда
        ФС.АтрибутыФайла(прИмяФайла,лпРазмер,,,,,);
       
        Если (лпРазмер = РазмерФайлаФТП) Тогда
            Возврат 1;
        КонецЕсли;
    КонецЕсли;
   
    Возврат 0;
КонецФункции
Read 6381 times Last modified on Воскресенье, 15 Февраль 2015 13:35
Rate this item
(0 votes)
More in this category: ROM-Mail.dll crash 1c 7.7 »

Leave a comment

Make sure you enter all the required information, indicated by an asterisk (*). HTML code is not allowed.

Счетчики

Gallery

Киев, Новозабарская, 2/6

+38(044)361-0274        +38(044)383-7364