Blog

Items filtered by date: Июнь 2015

Нарыл скрипт в просторах интернета, который позваляет блокировать на mikrotik социальные сайты http и https. Пользователи могут зайти на сайт буквально пару минут (в зависимости как часто мы будем запускать скрипт), после чего сайт блокируется (если найдены ключевые слова). Очень удобно и главное работает.

:foreach i in=[/ip dns cache all find where (name~"facebook" || name~"youtube" || name~"ok.ru" || name~"video" || name~"vk.com" ) && (type="A") ] do={
:local tmpAddress [/ip dns cache get $i address];
delay delay-time=10ms
#prevent script from using all cpu time
:if ( [/ip firewall address-list find where address=$tmpAddress] = "") do={
:local cacheName [/ip dns cache get $i name] ;
:log info ("added entry: $cacheName $tmpAddress");
/ip firewall address-list add address=$tmpAddress list=block comment=$cacheName;
}
}

В первой строке мы забиваем в кавычках какие домены искать find where (name~"facebook" || name~"fbcdn" || name~"odnokl" ) . Если есть совпадения то мы закидываем ip адрес этого домена в адреслист с именем block.

Остается создать правило в файрволе, которое блочит адреслист block:

/ip firewall filter add chain
=forward dst-address-list=block src-address-list=!"HotSpot" action=reject reject-
with=icmp-host-prohibited disabled=no


Где src-address-list=!"HotSpot" говорит что правило работает для всех адресов, кроме забитых в адреслист "HotSpot" (т.е. там хранятся адреса тех кому можно ходить на соц сети :) ).
И обращаю в нимание на action - стоит reject, это для того что бы браузер не "повисал" когда обращается к этим ардесам, а сразу выдавал ошибку о том что сеть не доступна.

 

P.S. Осталось написать скрипт, который будет очищать время от времени адреслист block, а то как-то грязно будет)

Published in Mikrotik
Воскресенье, 21 Июнь 2015 00:00

Установка teamviewer на Ubuntu 14

На сайте teamviewer качаем deb 32-Bit / 64-Bit Multiarch.

Открываем Ubuntu software center - устанавливаем Gdebi packpage Installer (gdebi)

После установки кликаем правой кнопкой по скаченому deb пакету и выбираем “Open With Gebi Package Installer”

Открывается окошко - нажимаем Install packpage

 

Published in Linux
Воскресенье, 21 Июнь 2015 00:00

Установка Android SDK Linux

1) Качаем SDK Tools http://developer.android.com/sdk/index.html

2) Распаковываем в папку

3) Переходим в папку tools и запускаем файд android (с консоли sh android)

4) Открывается Android SDK manager

5) Устанавливаем нужные нам пакеты

По времени у меня заняло 30 минут

Published in Linux

Чтобы убрать это предупреждение, делаем следующее:

1) Заходим в каталог Android-studio /bin/studio64.vmoptions

2) Удаляем строку MaxPermSize=

Published in Linux
Пятница, 19 Июнь 2015 00:00

The CAR of HAPPINESS tizer

Published in Видео

Счетчики

Gallery

Contact us

Украина, Киев

P: +38(044) 361-0274